#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*[#%\/]*\s*(.*)[\n\r]"
Local $sString = "% x=(1:20)';" & @CRLF & _
"% y=randn(20,1);" & @CRLF & _
"% [bhat p wh se ci t_stat]=robust_fit(x,y,1);" & @CRLF & _
"% figure;plot(x,y,'.'); hold on; plot(x,bhat(1)+bhat(2).*x,'r')" & @CRLF & _
"% plot(x,[ones(length(x),1) x]*(([ones(length(x),1) x]'*[ones(length(x),1) x])\([ones(length(x),1) x]'*y)),'k')" & @CRLF & _
"% legend('Data','Robust','Non-robust')" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")