const regex = /^\s*[#%\/]*\s*(.*)[\n\r]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*[#%\\\/]*\\s*(.*)[\\n\\r]', 'gm')
const str = `% x=(1:20)';
% y=randn(20,1);
% [bhat p wh se ci t_stat]=robust_fit(x,y,1);
% figure;plot(x,y,'.'); hold on; plot(x,bhat(1)+bhat(2).*x,'r')
% plot(x,[ones(length(x),1) x]*(([ones(length(x),1) x]'*[ones(length(x),1) x])\\([ones(length(x),1) x]'*y)),'k')
% legend('Data','Robust','Non-robust')
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}