#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:```.*\s+|\s+```)"
Local $sString = "```html" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <meta name="viewport" content="width=device-width, initial-scale=1.0">" & @CRLF & _
" <title>BPA vs. RPA</title>" & @CRLF & _
" <style>" & @CRLF & _
" table {" & @CRLF & _
" width: 80%;" & @CRLF & _
" margin: 20px auto;" & @CRLF & _
" border-collapse: collapse;" & @CRLF & _
" font-family: Arial, sans-serif;" & @CRLF & _
" background-color: #f9f9f9;" & @CRLF & _
" box-shadow: 0 2px 5px rgba(0, 0, 0, 0.1);" & @CRLF & _
" }" & @CRLF & _
" th, td {" & @CRLF & _
" padding: 15px;" & @CRLF & _
" text-align: left;" & @CRLF & _
" border-bottom: 1px solid #ddd;" & @CRLF & _
" }" & @CRLF & _
" th {" & @CRLF & _
" background-color: #ff785b;" & @CRLF & _
" color: white;" & @CRLF & _
" text-transform: uppercase;" & @CRLF & _
" }" & @CRLF & _
" tr:hover {" & @CRLF & _
" background-color: #f1f1f1;" & @CRLF & _
" }" & @CRLF & _
" tr:nth-child(even) {" & @CRLF & _
" background-color: #f2f2f2;" & @CRLF & _
" }" & @CRLF & _
" </style>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
" <table>" & @CRLF & _
" <tr>" & @CRLF & _
" <th>Aspect</th>" & @CRLF & _
" <th>Manual Collection</th>" & @CRLF & _
" <th>API-Based Collection</th>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Speed</td>" & @CRLF & _
" <td>Slow</td>" & @CRLF & _
" <td>Fast</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Accuracy</td>" & @CRLF & _
" <td>3-4% error rate</td>" & @CRLF & _
" <td>Very accurate</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Data Volume</td>" & @CRLF & _
" <td>Limited</td>" & @CRLF & _
" <td>High capacity</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Cost</td>" & @CRLF & _
" <td>Higher (labor)</td>" & @CRLF & _
" <td>Lower long-term</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Consistency</td>" & @CRLF & _
" <td>Variable</td>" & @CRLF & _
" <td>Uniform</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
"</body>" & @CRLF & _
"```"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")