import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:```.*\\s+|\\s+```)";
final String string = "```html\n"
+ "<head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\">\n"
+ " <title>BPA vs. RPA</title>\n"
+ " <style>\n"
+ " table {\n"
+ " width: 80%;\n"
+ " margin: 20px auto;\n"
+ " border-collapse: collapse;\n"
+ " font-family: Arial, sans-serif;\n"
+ " background-color: #f9f9f9;\n"
+ " box-shadow: 0 2px 5px rgba(0, 0, 0, 0.1);\n"
+ " }\n"
+ " th, td {\n"
+ " padding: 15px;\n"
+ " text-align: left;\n"
+ " border-bottom: 1px solid #ddd;\n"
+ " }\n"
+ " th {\n"
+ " background-color: #ff785b;\n"
+ " color: white;\n"
+ " text-transform: uppercase;\n"
+ " }\n"
+ " tr:hover {\n"
+ " background-color: #f1f1f1;\n"
+ " }\n"
+ " tr:nth-child(even) {\n"
+ " background-color: #f2f2f2;\n"
+ " }\n"
+ " </style>\n"
+ "</head>\n"
+ "<body>\n"
+ " <table>\n"
+ " <tr>\n"
+ " <th>Aspect</th>\n"
+ " <th>Manual Collection</th>\n"
+ " <th>API-Based Collection</th>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>Speed</td>\n"
+ " <td>Slow</td>\n"
+ " <td>Fast</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>Accuracy</td>\n"
+ " <td>3-4% error rate</td>\n"
+ " <td>Very accurate</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>Data Volume</td>\n"
+ " <td>Limited</td>\n"
+ " <td>High capacity</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>Cost</td>\n"
+ " <td>Higher (labor)</td>\n"
+ " <td>Lower long-term</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>Consistency</td>\n"
+ " <td>Variable</td>\n"
+ " <td>Uniform</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ "</body>\n"
+ "```";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}