using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9_.\-]+@(?:mail\.ru|yandex\.ru|gmail\.com):.+";
string input = @"login@mail.ru:pass
login@yandex.ru:пасс
login@gmail.com:пасс
login@xz.com:пасс
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}