$re = '/[a-zA-Z0-9_.\-]+@(?:mail\.ru|yandex\.ru|gmail\.com):.+/m';
$str = 'login@mail.ru:pass
login@yandex.ru:пасс
login@gmail.com:пасс
login@xz.com:пасс
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);