import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(week.*)";
final String string = "_9978967868768763ghjgj7598983678hjva_week1-6.pdf\n"
+ "_78637832bdsjh275637bkkaww786b_week12-32.pdf\n"
+ "8786767867868978713bkwkhjhkjqw_week1-622.pdf\n"
+ "867813567bdjsbgbadsyu6712353125561235_week100-6.pdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}