# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(week.*)"
test_str = ("_9978967868768763ghjgj7598983678hjva_week1-6.pdf\n"
"_78637832bdsjh275637bkkaww786b_week12-32.pdf\n"
"8786767867868978713bkwkhjhkjqw_week1-622.pdf\n"
"867813567bdjsbgbadsyu6712353125561235_week100-6.pdf")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.