#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/user\/?[0-9]+\/(?!deposit|withdraw).+$"
Local $sString = "/user/123/not-withdraw" & @CRLF & _
"/user/123/not-deposit" & @CRLF & _
"" & @CRLF & _
"/user/123/withdraw" & @CRLF & _
"/user/123/deposit/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")