const regex = /^\/user\/?[0-9]+\/(?!deposit|withdraw).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/user\\\/?[0-9]+\\\/(?!deposit|withdraw).+$', 'gm')
const str = `/user/123/not-withdraw
/user/123/not-deposit
/user/123/withdraw
/user/123/deposit/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}