import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>\\G(?!^)|^(?:.*?[^\\p{P}\\h\\d\\n])?[\\p{P}\\h]*+1?(?=(?1){10}(?!(?1))))((\\d)[\\p{P}\\h]*+)(?:[^\\d\\n].*)?";
final String string = " +18005551212\n"
+ " 8005551213\n"
+ " 18005551214\n"
+ " (800)555-1215\n"
+ " 800.555.1216\n"
+ " (800) 555-1217\n"
+ " 800 555 12 18\n"
+ " \n"
+ " stuff before +18005551221 stuff after\n"
+ " stuff before 8005551222 stuff after\n"
+ " stuff before 18005551223 stuff after\n"
+ " stuff before (800)555-1224 stuff after\n"
+ " stuff before 800.555.1225 stuff after\n"
+ " stuff before (800) 555-1226 stuff after\n"
+ " stuff before 800 555 12 27 stuff after\n"
+ " \n"
+ " 5551212";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}