# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?>\G(?!^)|^(?:.*?[^\p{P}\h\d\n])?[\p{P}\h]*+1?(?=(?1){10}(?!(?1))))((\d)[\p{P}\h]*+)(?:[^\d\n].*)?"
test_str = (" +18005551212\n"
" 8005551213\n"
" 18005551214\n"
" (800)555-1215\n"
" 800.555.1216\n"
" (800) 555-1217\n"
" 800 555 12 18\n"
" \n"
" stuff before +18005551221 stuff after\n"
" stuff before 8005551222 stuff after\n"
" stuff before 18005551223 stuff after\n"
" stuff before (800)555-1224 stuff after\n"
" stuff before 800.555.1225 stuff after\n"
" stuff before (800) 555-1226 stuff after\n"
" stuff before 800 555 12 27 stuff after\n"
" \n"
" 5551212")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.