const regex = /(?:https?:\/\/)?(?:www\.)?(?:m\.)?(?:youtu\.be\/|youtube\.com\/(?:(?:watch)?\?(?:\S*&)?vi?=|(?:embed|v|vi|user|shorts)\/))([^?&\"'>\s]+)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/)?(?:www\\.)?(?:m\\.)?(?:youtu\\.be\\\/|youtube\\.com\\\/(?:(?:watch)?\\?(?:\\S*&)?vi?=|(?:embed|v|vi|user|shorts)\\\/))([^?&\\"\'>\\s]+)', 'gms')
const str = `this is a test https://www.youtube.com/watch?v=d4bv2NaO9fQ this is a test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}