re = /(?:https?:\/\/)?(?:www\.)?(?:m\.)?(?:youtu\.be\/|youtube\.com\/(?:(?:watch)?\?(?:\S*&)?vi?=|(?:embed|v|vi|user|shorts)\/))([^?&\"'>\s]+)/m
str = 'this is a test https://www.youtube.com/watch?v=d4bv2NaO9fQ this is a test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end