package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}`)
var str = ` 192.168.0.1 - 192.168.0.5 gcgh 192.168.0.7gcgh 192.168.0.7 gcgh 192.168.0.8 gcgh 192.168.0.9 gcgh
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}