$re = '/\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}/m';
$str = ' 192.168.0.1 - 192.168.0.5 gcgh 192.168.0.7gcgh 192.168.0.7 gcgh 192.168.0.8 gcgh 192.168.0.9 gcgh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);