package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)\s+(\d+)(?:;\s+)?`)
var str = `Mercedes 2000; BMW 2500; Audi 2000; Porsche 1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}