// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\S+)\s+(\d+)(?:;\s+)?").unwrap();
let string = "Mercedes 2000; BMW 2500; Audi 2000; Porsche 1000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}