$re = '/\|\s*((?!\s*\w+:\/\/)[^|]+?)\s\|/m';
$str = 'https://stackoverflow.com | https://google.com | This is quite an inte
resting sentence, isn\'t it? |
https://randomsite.com | https://randomurl2.com | text | https://randomsite.com |
https://randomsite.com | https://randomsite.com |
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);