re = /\|\s*((?!\s*\w+:\/\/)[^|]+?)\s\|/m
str = 'https://stackoverflow.com | https://google.com | This is quite an inte
resting sentence, isn\'t it? |
https://randomsite.com | https://randomurl2.com | text | https://randomsite.com |
https://randomsite.com | https://randomsite.com |
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end