#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(a);(.*?);(.*?)|.*)$"
Local $sString = "a;b;c" & @CRLF & _
"a;x;23" & @CRLF & _
"b;b;12"
Local $sSubst = "\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)