using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(a);(.*?);(.*?)|.*)$";
string substitution = @"\3";
string input = @"a;b;c
a;x;23
b;b;12";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}