using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"procs=([^;]+)\S+";
string substitution = @"\1";
string input = @"DATATYPE::SERVICEPERFDATA TIMET::1519222690 HOSTNAME::localhost SERVICEDESC::Total Processes SERVICEPERFDATA::procs=59;250;400;0; SERVICECHECKCOMMAND::check_local_procs!250!400!RSZDT HOSTSTATE::UP HOSTSTATETYPE::HARD SERVICESTATE::OK SERVICESTATETYPE::HARD";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}