package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`procs=([^;]+)\S+`)
var str = `DATATYPE::SERVICEPERFDATA TIMET::1519222690 HOSTNAME::localhost SERVICEDESC::Total Processes SERVICEPERFDATA::procs=59;250;400;0; SERVICECHECKCOMMAND::check_local_procs!250!400!RSZDT HOSTSTATE::UP HOSTSTATETYPE::HARD SERVICESTATE::OK SERVICESTATETYPE::HARD`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}