const regex = /^START\b.*(?:\R(?!START\b|END_OF_MSG\b).*)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^START\\b.*(?:\\R(?!START\\b|END_OF_MSG\\b).*)*', 'gm')
const str = `HELLO
START ABC DEF GHI JKL
QWER RANDOM TEXT 213%@#!
UIOP RANDOMZXCVB123456
START ABC DEF GHI JKL
ZZZZZ RANDOMTEXT213%@#!
11111 RANDOMZXCVB123456
\$\$\$\$\$\$ SOMEMORETEXT
START ABC DEF GHI JKL
QWER RANDOMTEXT213%@#!
\$\$\$\$\$ RANDOMZXCVB123456
END_OF_MSG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}