#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[^'\n\r]*On Error Goto"
Local $sString = "Match:" & @CRLF & _
"" & @CRLF & _
"on error goto err_handler" & @CRLF & _
"if aap = 0 then on error goto Myerrorhandler" & @CRLF & _
" on error goto errorhandler1" & @CRLF & _
" on error goto errorhandler2" & @CRLF & _
"Do not match:" & @CRLF & _
"" & @CRLF & _
"' on error goto errorhandler3" & @CRLF & _
"' if aap =0 then on error goto errorhandler4" & @CRLF & _
"Any line not containing On Error Got0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")