const regex = /^[^'\n\r]*On Error Goto/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\'\\n\\r]*On Error Goto', 'gmi')
const str = `Match:
on error goto err_handler
if aap = 0 then on error goto Myerrorhandler
on error goto errorhandler1
on error goto errorhandler2
Do not match:
' on error goto errorhandler3
' if aap =0 then on error goto errorhandler4
Any line not containing On Error Got0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}