package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)正则查找部分`)
var str = `the little cat cat is in the hat hat hat, we like it.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}