$re = '/正则查找部分/m';
$str = 'the little cat cat is in the hat hat hat, we like it.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);