using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[0-9]*)([A-Z0-9]*?)(ROAD|STREET|AVENUE)?$";
string input = @"77BIGBEARROAD
77BIGBEAR45ROAD";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}