$re = '/(^[0-9]*)([A-Z0-9]*?)(ROAD|STREET|AVENUE)?$/m';
$str = '77BIGBEARROAD
77BIGBEAR45ROAD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);