$re = '/^(("?[\w\s]+"?): ?("[\w\s\']+")( (AND|OR) )?)+$/';
$str = 'Color: "Blue" AND Size: "Women\'s Large"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);