re = /^(("?[\w\s]+"?): ?("[\w\s']+")( (AND|OR) )?)+$/
str = 'Color: "Blue" AND Size: "Women\'s Large"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end