const regex = /\b(\d{1,3}(?:\.\d{1,3}){2}-[\dkK])\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d{1,3}(?:\\.\\d{1,3}){2}-[\\dkK])\\b', 'gm')
const str = `10.000.000-0 9.343.154-K 17.878.335-2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}