// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{1,3}(?:\.\d{1,3}){2}-[\dkK])\b").unwrap();
let string = "10.000.000-0 9.343.154-K 17.878.335-2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}