import re
regex = re.compile(r"\b(\d{1,3}(?:(\.?)\d{3}){2}(-?)[\dkK])\b", flags=re.MULTILINE)
test_str = "10.000.000-0 9.343.154-K 17.87.335-2 17.827.335--2 17878335-2 12345678K "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")