re = /\b(\d{1,3}(?:(\.?)\d{3}){2}(-?)[\dkK])\b/m
str = '10.000.000-0 9.343.154-K 17.87.335-2 17.827.335--2 17878335-2 12345678K '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end