re = /\(generic:(?<Field>[^\)]*)\)\(/
str = 'String = This is the string (generic:ggmail.com)(3245612)
= This is the string (generic:abcdexadsfsdf.cc)(1232143)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end