using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<=<array>)(?:((?!<\/array>).)*?[*]){2}(?1)*";
string input = @"<array>blah blah * blah blah * blah blah</array>
<array>blah blah blah **blah blah blah</array>
<array>blah blah blah blah blah blah</array>
<array>blah blah blah *blah blah blah</array>
<array>blah blah * blah blah blah blah</array>
<array>blah blah blah blah blah blah</array>
<array>blah blah blah **blah blah blah</array>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}