$re = '/(?s)(?<=<array>)(?:((?!<\/array>).)*?[*]){2}(?1)*/';
$str = '<array>blah blah * blah blah * blah blah</array>
<array>blah blah blah **blah blah blah</array>
<array>blah blah blah blah blah blah</array>
<array>blah blah blah *blah blah blah</array>
<array>blah blah * blah blah blah blah</array>
<array>blah blah blah blah blah blah</array>
<array>blah blah blah **blah blah blah</array>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);