#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)$"
Local $sString = "1-10RD724" & @CRLF & _
"1-I94YUBU" & @CRLF & _
"1-HRF87G6" & @CRLF & _
"1-FV4IAE3" & @CRLF & _
"1-E30MNAI" & @CRLF & _
"1-10RD724" & @CRLF & _
"1-ED94GUQ" & @CRLF & _
"1-4J1QEY1"
Local $sSubst = ",$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)