# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*)$"
test_str = ("1-10RD724\n"
"1-I94YUBU\n"
"1-HRF87G6\n"
"1-FV4IAE3\n"
"1-E30MNAI\n"
"1-10RD724\n"
"1-ED94GUQ\n"
"1-4J1QEY1")
subst = ",$1,Closed/No-Sale,Abandoned,requested by WL8573,09/08/2023"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.