# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?<!(?<!\A)\G)\s*$/<line break>/gm;t' <<< "
Here is some text.
After several lines of whitespace, here is some more text."