using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<!(?<!\A)\G)\s*$";
string substitution = @"<line break>";
string input = @"
Here is some text.
After several lines of whitespace, here is some more text.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}