#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s{4}\/\*\*\n\s+\*\s@see\s[a-zA-Z\.#\(,\*\s\)]+\*\/"
Local $sString = " /**" & @CRLF & _
" * @see duke.webapp.struts.DukeDispatchAction#executeDefault(org.apache.struts.action.ActionMapping," & @CRLF & _
" * org.apache.struts.action.ActionForm, javax.servlet.http.HttpServletRequest," & @CRLF & _
" * javax.servlet.http.HttpServletResponse)" & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")