package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[A-Za-z] ){2,}[A-Za-z]`)
var str = `Mengkapan,Sungai Apit,S I A K,Riau,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}