$re = '/(?:[A-Za-z] ){2,}[A-Za-z]/m';
$str = 'Mengkapan,Sungai Apit,S I A K,Riau,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);