const regex = /^[a-z0-9][a-z0-9-_\.]+@[a-z0-9][a-z0-9-]+[a-z0-9]\.[a-z0-9]{2,10}(?:\.[a-z]{2,10})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9][a-z0-9-_\\.]+@[a-z0-9][a-z0-9-]+[a-z0-9]\\.[a-z0-9]{2,10}(?:\\.[a-z]{2,10})?$', '')
const str = `demo@genteflow-s.pe.ar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}