re = /^[a-z0-9][a-z0-9-_\.]+@[a-z0-9][a-z0-9-]+[a-z0-9]\.[a-z0-9]{2,10}(?:\.[a-z]{2,10})?$/
str = 'demo@genteflow-s.pe.ar'
# Print the match result
str.match(re) do |match|
puts match.to_s
end