import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{8}$)(?=.*[a-z])(?=.*[0-9])(?:(?:[a-z]+|[0-9]+)(?:-|$)){3}";
final String string = "aa-99-99\n"
+ "99-23-bd\n"
+ "02-xx-04\n"
+ "ab-99-cz\n"
+ "sc-xd-49\n"
+ "99-xav-4\n"
+ "48-xyz-09\n"
+ "9-abc-01\n"
+ "xs-899-x\n"
+ "sss-99-x\n"
+ "10-b1-c2\n"
+ "aa-bb-01\n"
+ "10-11-ac\n"
+ "11-11-11\n"
+ "aa-bb-cc\n"
+ "11-bb-cc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}